Ubuntu Jaunty on Notebook

My notebook: Fujitsu V1020

Things that have been fixed since last release:

1. Screen brightness: xrandr is not required anymore. Great.

2. No more password for accessing the keyring (for wireless connection)

3. Wireless works with suspend.

Things that do not work out of the box:

1. Slow speed of WiFi:

The speed of WiFi is 1 or 2 Mbps by default. Solution from: http://wireless.kernel.org/en/users/Drivers/ath5k

iwconfig wlan0 rate 11M

(Do I need to do this every time?)

2. Sound: internal speakers do not mute when headphone is plugged in (keyword: jack sensing / auto-mute). Tried a bunch of things but still haven’t find out the right way:

head -n 1 /proc/asound/card0/codec#* returns ALC268 and LSI ID 1040

lspci | grep Audio returns 00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

Installed module-assistant as suggested on some websites:
sudo apt-get install module-assistant
sudo m-a a-i alsa-source
After a while and after reboot, I found that there are one less device to choose from… I cannot adjust headphone and speaker separately… oops. (How can I roll back?…)

Added a line to /etc/modprobe.d/alsa-base.conf: options snd-hda-intel model=xxx
where I’ve tried xxx=test, 3stack, 5stack, toshiba, fujitsu, auto… sigh
Maybe it’s due to the previous step??

Things to be figured out:

1. Do I need a swap partition in order to use hibernation? or should I use TuxonIce? (update: after adding a swap partition hibernation works fine. Nice.)

標籤: , , ,

3 回應 to “Ubuntu Jaunty on Notebook”

  1. Jesse Says:

    as to the hibernation problem, hmm the quick way to go is to allocate a swap partition … You don’t need a full-size swap (provided you have 2 or 3 GB of ram), I have a 1.5G swap on my notebook, and in my case the hibernate image is about ~500MB (~124 thousand pages)

    Of course I’d love to see somebody try out TuxOnIce so I can learn something from that😉

    as to your sound card, lspci is not specific enough … Did you try the alsa doc I sent you? I found the (almost) exact chip used in my Presario, and found the horse according to the picture😛

  2. Adam Wang Says:

    Hi Tom,

    I bought a laptop same as yours Fujitsu V1020, I installed Ubuntu9.04 which also met the all problems you had have. But currently I use this set to do other project, so haven’t tried any solution to fix them. I was so glad that you posted the ways how to and try to.

    Adam

  3. ivan Says:

    As to the auto-mute, had the same problem with intel sound on a different notebook. Installing the 2.6.31 kernel and alsa-* from karmic fixed the problem and everything seems to work fine.

    I also updated nvidia but that’s unrelated, I suppose.

發表迴響

在下方填入你的資料或按右方圖示以社群網站登入:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / 變更 )

Twitter picture

You are commenting using your Twitter account. Log Out / 變更 )

Facebook照片

You are commenting using your Facebook account. Log Out / 變更 )

Google+ photo

You are commenting using your Google+ account. Log Out / 變更 )

連結到 %s


%d 位部落客按了讚: